#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*\/([^/]*)-.*"
Local $sString = "http://www.mega.pk/**washingmachine**-dawlance/" & @CRLF & _
"http://www.mega.pk/**washingmachine**-haier/" & @CRLF & _
"http://www.mega.pk/**airconditioners**-acson/" & @CRLF & _
"http://www.mega.pk/**airconditioners**-lg/" & @CRLF & _
"http://www.mega.pk/**airconditioners**-samsung/"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)