#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<a(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')|[^>\s]+))?)*\s*(?:(value)\s*=\s*(?:"([^"]*)"))(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')|[^>\s]+))?)*\s*>"
Local $sString = "<p>" & @CRLF & _
"" & @CRLF & _
" <a readonly href="blah" value="page({page: '23032092'})" data-attr data-value='he-asd90lo' data-value-two="2">Link Here</a>" & @CRLF & _
"" & @CRLF & _
" <a readonly href="blah" value="page({page: 23032092})" data-attr data-value='he-asd90lo' data-value-two="2" ng-if="abc 0 && abc 0">" & @CRLF & _
"" & @CRLF & _
" <a></a>" & @CRLF & _
"" & @CRLF & _
" <a ></a>" & @CRLF & _
"" & @CRLF & _
" <a readonly " & @CRLF & _
" ></a>" & @CRLF & _
"" & @CRLF & _
" <a " & @CRLF & _
" ></a>" & @CRLF & _
"(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')))" & @CRLF & _
"</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")