import Foundation
let pattern = #"<a(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')|[^>\s]+))?)*\s*(?:(value)\s*=\s*(?:"([^"]*)"))(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')|[^>\s]+))?)*\s*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<p>
<a readonly href="blah" value="page({page: '23032092'})" data-attr data-value='he-asd90lo' data-value-two="2">Link Here</a>
<a readonly href="blah" value="page({page: 23032092})" data-attr data-value='he-asd90lo' data-value-two="2" ng-if="abc 0 && abc 0">
<a></a>
<a ></a>
<a readonly
></a>
<a
></a>
(?:\s*=\s*(?:(?:"[^"]*")|(?:'[^']*')))
</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)