$re = '/<a(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:\'[^\']*\')|[^>\s]+))?)*\s*(?:(value)\s*=\s*(?:"([^"]*)"))(?:\s+[\w:-]+(?:\s*=\s*(?:(?:"[^"]*")|(?:\'[^\']*\')|[^>\s]+))?)*\s*>/mi';
$str = '<p>
<a readonly href="blah" value="page({page: \'23032092\'})" data-attr data-value=\'he-asd90lo\' data-value-two="2">Link Here</a>
<a readonly href="blah" value="page({page: 23032092})" data-attr data-value=\'he-asd90lo\' data-value-two="2" ng-if="abc 0 && abc 0">
<a></a>
<a ></a>
<a readonly
></a>
<a
></a>
(?:\\s*=\\s*(?:(?:"[^"]*")|(?:\'[^\']*\')))
</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);