#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Profile\/(\d+)[\S\s]*Allan[\S\s]*AddAnswer(\d+)"
Local $sString = "<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,'GET','');" class="reportLink">" & @CRLF & _
" report </a>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class="details">" & @CRLF & _
" <p class="content">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Hi there, Allan." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </p>" & @CRLF & _
"" & @CRLF & _
" <div id="AddAnswer1234523453245"></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")