using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Profile\/(\d+)[\S\s]*Allan[\S\s]*AddAnswer(\d+)";
string input = @"<h4><a href=""/Profile/23423423423.html"">@@@@@@</a> </h4> said12:49:32
</div>
<a href=""javascript:void(0)"" onclick=""replyAnswer(@@@@@@@@@@,'GET','');"" class=""reportLink"">
report </a>
</div>
<div class=""details"">
<p class=""content"">
Hi there, Allan.
</p>
<div id=""AddAnswer1234523453245""></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}