re = /Profile\/(\d+)[\S\s]*Allan[\S\s]*AddAnswer(\d+)/
str = '<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32
</div>
<a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,\'GET\',\'\');" class="reportLink">
report </a>
</div>
<div class="details">
<p class="content">
Hi there, Allan.
</p>
<div id="AddAnswer1234523453245"></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end