#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(<[a-z][a-z0-0]*[^>]*>))"
Local $sString = "<div class="" id="">" & @CRLF & _
"" & @CRLF & _
" <div style=""><b></b></div>" & @CRLF & _
"" & @CRLF & _
" <span></span>" & @CRLF & _
"" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")