using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(<[a-z][a-z0-0]*[^>]*>))";
string input = @"<div class="" id="">
<div style=""><b></b></div>
<span></span>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}