re = /(?:(<[a-z][a-z0-0]*[^>]*>))/
str = '<div class="" id="">
<div style=""><b></b></div>
<span></span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end