$re = '/(?:(<[a-z][a-z0-0]*[^>]*>))/';
$str = '<div class="" id="">
<div style=""><b></b></div>
<span></span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);