import Foundation
let pattern = #"(?=(^\d\s{3}(chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?=(?:(?:\s+[01]/[01])*?\s+1/1){3})(?:(?:(?:\s+[01]/[01])*?\s+0/0){3})(?:\s+[01]/[01])*\s(^\d\s{3}((chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?:\s+[01]/[01])*\s)){1,2}^\d\s{3}(chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?=(?:(?:\s+[01]/[01])*?\s+1/1){3})(?:(?:(?:\s+[01]/[01])*?\s+0/0){3})(?:\s+[01]/[01])*\s))|(^\d\s{3}(chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?=(?:(?:\s+[01]/[01])*?\s+1/1){3})(?:(?:(?:\s+[01]/[01])*?\s+0/0){3})(?:\s+[01]/[01])*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0 chr1 1152 NaN G A 1355.64 NaN 1/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
4 chr1 1331 NaN A C 4171.07 NaN 0/0 0/1 0/1 0/1 0/0 0/1 0/1 0/1 0/1 0/0 0/1 0/1
5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 1/1 1/1 1/1 0/1 1/1 0/1 1/1 0/1 1/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 1/1 1/1 1/1 0/1 1/1 0/1 1/1 0/1 1/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)