import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{3}\\.\\d{3}\\.\\d{1,3}$)|(^\\d{3}\\.\\d{1,3}$)|(^\\d{3}$)";
final String string = "123\n"
+ "123.4\n"
+ "123.44\n"
+ "123.445\n"
+ "123.33.3\n"
+ "123.3.3\n"
+ "123.333.3\n"
+ "123.333.34\n"
+ "123.333.344";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}