$re = '/(^\d{3}\.\d{3}\.\d{1,3}$)|(^\d{3}\.\d{1,3}$)|(^\d{3}$)/m';
$str = '123
123.4
123.44
123.445
123.33.3
123.3.3
123.333.3
123.333.34
123.333.344';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);