import re
regex = re.compile(r"(^\d{3}\.\d{3}\.\d{1,3}$)|(^\d{3}\.\d{1,3}$)|(^\d{3}$)", flags=re.MULTILINE)
test_str = ("123\n"
"123.4\n"
"123.44\n"
"123.445\n"
"123.33.3\n"
"123.3.3\n"
"123.333.3\n"
"123.333.34\n"
"123.333.344")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")