re = /(^\d{3}\.\d{3}\.\d{1,3}$)|(^\d{3}\.\d{1,3}$)|(^\d{3}$)/m
str = '123
123.4
123.44
123.445
123.33.3
123.3.3
123.333.3
123.333.34
123.333.344'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end