#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[\[,])(\d+)(?=[\],])"
Local $sString = "сенсор-1 [86] скорость 85 сенсор-2 [44]. Фотоцентры 13 массы [86,13] плотность [46]. Функц. [1]. ретиналь [13] фотоактивность [32] массы-2 [13,32]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")