$re = '/(?<=[\[,])(\d+)(?=[\],])/m';
$str = 'сенсор-1 [86] скорость 85 сенсор-2 [44]. Фотоцентры 13 массы [86,13] плотность [46]. Функц. [1]. ретиналь [13] фотоактивность [32] массы-2 [13,32]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);