re = /(?<=[\[,])(\d+)(?=[\],])/m
str = 'сенсор-1 [86] скорость 85 сенсор-2 [44]. Фотоцентры 13 массы [86,13] плотность [46]. Функц. [1]. ретиналь [13] фотоактивность [32] массы-2 [13,32]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end