import Foundation
let pattern = #"(?<=[\[,])(\d+)(?=[\],])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"сенсор-1 [86] скорость 85 сенсор-2 [44]. Фотоцентры 13 массы [86,13] плотность [46]. Функц. [1]. ретиналь [13] фотоактивность [32] массы-2 [13,32]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)