package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\\[a-zA-Z0-9]{3})`)
var str = `Aarskog\xc3\xa2\xc2\x80\xc2\x93Scott syndrome`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}