// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\\[a-zA-Z0-9]{3})").unwrap();
let string = "Aarskog\\xc3\\xa2\\xc2\\x80\\xc2\\x93Scott syndrome";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}