package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^line3$`)
var str = `line1
line2
line3line4
line5line3
line3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}