$re = '/^line3$/m';
$str = 'line1
line2
line3line4
line5line3
line3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);