package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d.|-]+`)
var str = `# sample output: 11:53:00p|0.0mm|1028.11s|75%|-4|`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}