import re
regex = re.compile(r"[^\d.|-]+")
test_str = "# sample output: 11:53:00p|0.0mm|1028.11s|75%|-4|"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)