use strict;
my $str = '# sample output: 11:53:00p|0.0mm|1028.11s|75%|-4|';
my $regex = qr/[^\d.|-]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";