#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(h|v) )?(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)\s+(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)"
Local $sString = "h 1 1 100.5 100 (в результате S='h', x1=1, y1=1, x2=100.5, y2=100)" & @CRLF & _
"v 1,1 100,100.5" & @CRLF & _
"1,1 100.5,100 (в результате S=defaultS, point1 = (1,1), point2 = (100.5,100))" & @CRLF & _
"1 1 100 100.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")