$re = '/^(?:(h|v) )?(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)\s+(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)/m';
$str = 'h 1 1 100.5 100 (в результате S=\'h\', x1=1, y1=1, x2=100.5, y2=100)
v 1,1 100,100.5
1,1 100.5,100 (в результате S=defaultS, point1 = (1,1), point2 = (100.5,100))
1 1 100 100.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);