use strict;
my $str = 'h 1 1 100.5 100 (в результате S=\'h\', x1=1, y1=1, x2=100.5, y2=100)
v 1,1 100,100.5
1,1 100.5,100 (в результате S=defaultS, point1 = (1,1), point2 = (100.5,100))
1 1 100 100.5';
my $regex = qr/^(?:(h|v) )?(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)\s+(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}