import Foundation
let pattern = #"^(?:(h|v) )?(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)\s+(\d+(?:\.\d+)?)(?:\s+|\s*,\s*)(\d+(?:\.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
h 1 1 100.5 100 (в результате S='h', x1=1, y1=1, x2=100.5, y2=100)
v 1,1 100,100.5
1,1 100.5,100 (в результате S=defaultS, point1 = (1,1), point2 = (100.5,100))
1 1 100 100.5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)