package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$`)
var str = `0566227662
0566227662
0041566227662
+41566227662`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}