const regex = /^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((00|\\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$', 'gm')
const str = `0566227662
0566227662
0041566227662
+41566227662`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}