import re
regex = re.compile(r"^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$", flags=re.MULTILINE)
test_str = ("0566227662\n"
"0566227662\n"
"0041566227662\n"
"+41566227662")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")