using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\w\/-]+))|;(?:(?!VALUE|TZID)\w+=[a-zA-Z0-9_\-\/]+))+:(?<value>(?:.*))";
string input = @"RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}