using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tion|[aeiou]";
string substitution = @"-$0";
string input = @"celebrationing";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}