use strict;
my $str = 'celebrationing';
my $regex = qr/tion|[aeiou]/p;
my $subst = '-$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";