import Foundation
let pattern = #"tion|[aeiou]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"celebrationing"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)