package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`tion|[aeiou]`)
var str = `celebrationing`
var substitution = "-$0"
fmt.Println(re.ReplaceAllString(str, substitution))
}