#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b(\w*?)([cf])(\w*))\b(?=[\s\S]*(\b\2(?!\3)[cf]\4))"
Local $sString = "came" & @CRLF & _
"cat" & @CRLF & _
"can" & @CRLF & _
"cans" & @CRLF & _
"fame" & @CRLF & _
"fast" & @CRLF & _
"fan" & @CRLF & _
"fans" & @CRLF & _
"rice" & @CRLF & _
"rife" & @CRLF & _
"cat" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")