using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b(\w*?)([cf])(\w*))\b(?=[\s\S]*(\b\2(?!\3)[cf]\4))";
string input = @"came
cat
can
cans
fame
fast
fan
fans
rice
rife
cat
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}