const regex = /(\b(\w*?)([cf])(\w*))\b(?=[\s\S]*(\b\2(?!\3)[cf]\4))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(\\w*?)([cf])(\\w*))\\b(?=[\\s\\S]*(\\b\\2(?!\\3)[cf]\\4))', 'g')
const str = `came
cat
can
cans
fame
fast
fan
fans
rice
rife
cat
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}