import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=.{2,17}$)\\d+\\.\\d+|\\d{1,16})$";
final String string = "9999999999999999\n"
+ "0.000000000000001\n"
+ "3.24\n"
+ "1.2\n"
+ "0.00003\n"
+ "12345678910111213\n"
+ "59.492.5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}