const regex = /^(?:(?=.{2,17}$)\d+\.\d+|\d{1,16})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=.{2,17}$)\\d+\\.\\d+|\\d{1,16})$', 'gm')
const str = `9999999999999999
0.000000000000001
3.24
1.2
0.00003
12345678910111213
59.492.5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}