$re = '/^(?:(?=.{2,17}$)\d+\.\d+|\d{1,16})$/m';
$str = '9999999999999999
0.000000000000001
3.24
1.2
0.00003
12345678910111213
59.492.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);