use strict;
my $str = '9999999999999999
0.000000000000001
3.24
1.2
0.00003
12345678910111213
59.492.5';
my $regex = qr/^(?:(?=.{2,17}$)\d+\.\d+|\d{1,16})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}