#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[[^]]+\]"
Local $sString = "<td style="vertical-align: top; border: 1px solid gray;">[COMMENT2]</td>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)