// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[[^]]+\]").unwrap();
let string = "<td style=\"vertical-align: top; border: 1px solid gray;\">[COMMENT2]</td>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}