const regex = /\[[^]]+\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[^]]+\\]', '')
const str = `<td style="vertical-align: top; border: 1px solid gray;">[COMMENT2]</td>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);