$re = '/\[[^]]+\]/';
$str = '<td style="vertical-align: top; border: 1px solid gray;">[COMMENT2]</td>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;